Investigating Volunteer Opportunity Unexpected Behavior

Minor incident Volunteer Portal Admin Dashboard
2026-01-27 10:36 PST · 1 week, 3 days, 2 hours, 44 minutes

Updates

Resolved

These issues were monitored throughout the week of 2/1/2025 - 2/6/2025 and are believed to be resolved. Please reach out to support with any new reports of unexpected behavior within the Volunteer platform.

February 6, 2026 · 13:19 PST
Monitoring

We have detected issues in the Volunteer Admin and Volunteer facing portal/hub and we are currently monitoring the fix. Please continue to monitor this page for further updates and resolution.

January 27, 2026 · 10:36 PST

← Back